PDA

View Full Version : What happened to shipment?



Totoland Mach
Jul 9th, 2004, 03:26 AM
I ordered several products in late June and still have not received them (July 9th). I sent a request via the Meguiar's web site (contact us) and nobody responded. I called this morning and was told it shipped June 30th. Living in the middle of the US, it should have made the trip from either coast. I asked for a tracking number and was told it would be e-mailed today. Still haven't received that either.

It appears that e-mail is not a good medium for checking on order or shipment status.

Any suggestions?

Richard Seward
Overland Park Kansas

Lynn Matthews
Jul 9th, 2004, 04:34 AM
Richard,
I just checked with Jose in Customer Care (you placed your orig. order with him) and he said that your items that you ordered on June 29th were shipped on June 30th to Shawnee Mission, KS. He did not have access to the tracking number as the warehouse is in TN and everyone has gone home for the day.

Please give Jose a call at (800) 347-5700 Ext. 113 tomorrow as he will be checking into it again in the morning. If there is a problem with the shipment (lost/damaged) Meguiar’s will ship out a new order via overnight at no charge to you.

Thank you for your cooperation! ;)

Lynn Phillips
Meguiar’s Online Admin.

Totoland Mach
Jul 9th, 2004, 07:01 AM
Lynn: Thank you for the quick response! I'll call Jose in the morning and see what he found as far as the shipment information.

I appreciate the response...

See Ya From Toto Land