PDA

View Full Version : dacp #80 still trying to figure it out!



cheapthrills
Oct 14th, 2004, 04:16 PM
need some serious help! i am on the verge of throwing all my stuff up on ebay. :wall:

this was my situation i used dacp and megs cutting pad loading the pad 2 times and working 2 times, this left surface swirl free finish and fine scatches were gone. 80 a few times to remove hazing, the hazing was very light now. just today i tried to tackle another hazed area, i used a new polishing pad and some #80, the hazing got worse? i noticed the new pad was stiffer as the other one i used for 80 got soft? :wall:

some one please help, i'm going down fast.

i hear people getting good result with lake country orange pad?

is this a good pad for use with dacp?

by the way the new meguire's polishing pad i used with #80 fell apart, the velcro came right off, after two passes.

today was not a good day:(

travisdecpn
Oct 14th, 2004, 04:20 PM
Are you priming the pad with QD?

Mike Phillips
Oct 14th, 2004, 04:25 PM
Originally posted by cheapthrills
by the way the new Meguiar's polishing pad i used with #80 fell apart, the velcro came right off, after two passes.

today was not a good day:(

What speed are you running the dual action polisher?

How much pressure are you applying?

6 of us buffed out a 20' long Bentley last night using #80 Speed Glaze with a polishing pad on the dual action polisher and we experienced no problems and the car came out great!

http://archive.meguiarsonline.com/gallery/data/500/2RollsFinished1.jpg


Mike

cheapthrills
Oct 14th, 2004, 04:34 PM
i used speed 5 or a notch or two above 5.2, i am applying very little pressure, just enough to secure the pad to the finish, i would say about 6 pounds.

that rolls looks sweet! i haven't seen one in a while.

Mike Phillips
Oct 14th, 2004, 04:45 PM
Originally posted by cheapthrills
i used speed 5 or a notch or two above 5.2, i am applying very little pressure, just enough to secure the pad to the finish, i would say about 6 pounds.

that rolls looks sweet! i haven't seen one in a while.

Whoops!

My mistake, it's a Bentley, the owner brought it to a Rolls Royce class and I have Rolls Royce stuck in my brain when I think of this car...

Can you PM me your phone number and I'll call you to discuss...

Mike

cheapthrills
Oct 14th, 2004, 05:14 PM
Mike thanks for all your help, i really appreciate it.

SprintKing
Oct 14th, 2004, 05:17 PM
now thats service!!