Problems with UW
Results 1 to 10 of 10

Thread: Problems with UW

          
  1. #1
    Registered Member jwrsxts's Avatar
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    14

    Problems with UW

    Started using Ultimate Liquid Wax and I no matter how thin I apply it, it will never dries completely. I sometimes wait several hours before removing. Swipe test never works. When removing, it will smear and also difficult to remove. I did not have this problem with NXT 2.0.

    Car color is black. Any suggestion? Or is this normal?

    Thanks

  2. #2
    Registered Member Murr1525's Avatar
    Join Date
    Oct 2004
    Location
    Pittsburgh, PA
    Age
    39
    Posts
    19,083
    Rep Power
    235

    Re: Problems with UW

    Well, obviously not what is supposed to happen.

    But will be interested, as I will do my spring cleaning and try it in a couple weeks.
    2017 Subaru WRX Premium - WR Blue

  3. #3
    Registered Member
    Join Date
    Jan 2006
    Posts
    152
    Rep Power
    15

    Re: Problems with UW

    I think the swipe test does not work with UW.

  4. #4
    Sr. Global Product & Training Spec Michael Stoops's Avatar
    Join Date
    Oct 2004
    Location
    Irvine, CA
    Posts
    21,401
    Rep Power
    1137

    Re: Problems with UW

    Two things you can do here, and it has been discussed in other threads regarding Ultimate Liquid Wax:

    1. Apply to just a couple of panels at a time and wipe off after just 3-5 minutes, no longer. That should prevent any streaking or uneven appearance with the wax.

    2. Since you already have it applied, take a clean microfiber towel and spray a very fine mist of plain water onto it. You want a very small amount of water and can literally spray into the air and let it land on the towel. Now wipe a panel to even out the polymers in the ULW and your uneven appearance should go away.
    Michael Stoops
    Senior Global Product & Training Specialist | Meguiar's Inc.

    Remember, this hobby is supposed to be your therapy, not the reason you need therapy.

  5. #5
    Registered Member Murr1525's Avatar
    Join Date
    Oct 2004
    Location
    Pittsburgh, PA
    Age
    39
    Posts
    19,083
    Rep Power
    235

    Re: Problems with UW

    2017 Subaru WRX Premium - WR Blue

  6. #6
    Registered Member jwrsxts's Avatar
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    14

    Re: Problems with UW

    Thanks everyone for all your suggestions. I will give it another try. Looks like the wax will take a little more effort than NXT 2, but for the additional durability, I think it's worth the extra effort.

  7. #7
    Registered Member yalerd's Avatar
    Join Date
    Jan 2006
    Location
    Santo Domingo, Dominican Republic
    Posts
    4,439
    Rep Power
    120

    Re: Problems with UW

    Quote Originally Posted by Michael Stoops View Post
    1. Apply to just a couple of panels at a time and wipe off after just 3-5 minutes, no longer. That should prevent any streaking or uneven appearance with the wax.
    I've found this to work for me....In my case I wax the entire vehicle and remove it right away once I finish with waxing completely.

  8. #8
    Registered Member Kyle R's Avatar
    Join Date
    Jun 2010
    Location
    Charlotte
    Posts
    151
    Rep Power
    11

    Re: Problems with UW

    Exact same thing has been happening to me during my last two applications of it.... Ill have to try the methods listed above.....
    If you live around Charlotte, NC and would like your car detailed, PM me.

  9. #9
    Registered Member
    Join Date
    Feb 2010
    Location
    Monroe, NC
    Posts
    170
    Rep Power
    11

    Re: Problems with UW

    Same issues I had. Tried too many suggestions to count and none worked. Good luck.

  10. #10
    Registered Member wifpd4's Avatar
    Join Date
    Dec 2009
    Location
    Iowa
    Posts
    2,633
    Rep Power
    39

    Re: Problems with UW

    I'm sitting here knocking on wood as once I got it out of my system not to use the swipe test, I've had no problems. However on the last three black cars I've waited 1-2 hours to wipe off. One other crimson black car I did the short cycle wipe off and it was fine. The 1-2 hours is while I work on the interior or the wheels. Just takes that long, not really waiting on the wax.

    Due to an error, part of a car sat for 15-16 hours before wipe off. No problem.

    I love Ult Wax, so transparent and yet reflective.

    "fishing for swirls in a sea of black"
    ~~~~~~~~~~~~~~~~~~~~~~
    David

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cobalt with problems
    By wifpd4 in forum Show Off Your Latest Detail Work
    Replies: 4
    Last Post: Sep 29th, 2010, 05:45 AM
  2. Problems in my car lexus es350 2008
    By ES350 in forum Detailing 101
    Replies: 3
    Last Post: Apr 14th, 2010, 07:02 AM
  3. Brand new g110 having problems.... help
    By dedonderosa in forum Customer Service Hotline
    Replies: 7
    Last Post: Nov 4th, 2009, 01:12 PM
  4. tire problems
    By dnoraker in forum Detailing 101
    Replies: 7
    Last Post: Jul 9th, 2005, 07:27 PM
  5. Problems with swirls/hollograms on dark paint's
    By Jarlhov in forum Detailing 101
    Replies: 12
    Last Post: Jun 24th, 2004, 03:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •