Problems with Meguiars Ultimate Polish - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Problems with Meguiars Ultimate Polish

          
  1. #11
    Registered Member dwg51357's Avatar
    Join Date
    Jun 2013
    Location
    Iowa
    Posts
    57
    Rep Power
    8

    Re: Problems with Meguiars Ultimate Polish

    I had the same problem when I first used UP with a DA. Thanks to help from the Megs vets here, I learned that I was using too much product and not working it in enough. Now, for a 2x2' section, I use 3 or 4 tiny dabs of UP on the pad and work it slowly for 6 section passes in alternating directions, then wipe excess with MF towel. Also, am cleaning my pad with an old bath towel between sections. Results are terrific.

  2. #12
    Registered Member drumdan's Avatar
    Join Date
    Jan 2007
    Location
    Rochester Hills, Michigan
    Posts
    666
    Rep Power
    21
    Ultimate Polish has become one of my favorite products to use. It took me a minute to get used to it when it first arrived. I used it on an 09' Honda Civic yesterday, and even on their shiny, garage kept silver finish, UP deep cleaned the paint, and brought out a beatiful gloss, and reflection.

    I used it on a pc with a white ccs pad. Just like the user above me mentioned, three small dots of product, and six passes. I cleaned the pad after every other pass with a brush. No problems whatsoever. For me, less is more with UP.

  3. #13
    Sr. Global Product & Training Spec Michael Stoops's Avatar
    Join Date
    Oct 2004
    Location
    Irvine, CA
    Posts
    21,405
    Rep Power
    1139

    Re: Problems with Meguiars Ultimate Polish

    Wow, an extended discussion on an old revived thread - we don't see that too often!

    There is another potential issue going on here that has yet to be addressed. It is a bit surprising that the OPs issue is on a 2004 Subaru and not a brand new one, because we're getting numerous reports of new Subies using a paint that is very difficult to deal with. Specifically, on this new paint they're using it's darn tough to wipe anything off - compounds, polishes, waxes and from a wide variety of brands, not specifically our products. And these reports are coming in from very elite detailers across the US with years of experience doing absolutely top notch work. In short - these guys know every trick in the book.

    Our COO has a 2009 BMW M3 coupe that exhibits similar issues. It's the only car I've ever worked on personally that even M205 is a pain to wipe off of. And M205 is usually a breeze to work with. Doing two cars in the same day, including this BMW, is a real eye opener because on the first car everything just works the way one would expect it to, and then on this M3 it all just all just falls apart. Same day, same weather, same garage, same buffer, same bottle of M205 (or anything else) and it's just a huge fight with this car. Now, we know that there was some sort of an issue in the painting process at the factory with this car because a few years ago we did a full wet sand, cut and buff on it and there was extreme swelling of the paint during the compounding process, concealing the sanding marks and frustrating us to no end.

    The point here is that sometimes you come across a particular paint that just doesn't like a particular product (or, in the case of the newest Subarus, a paint that doesn't seem to like much of anything applied to it!). The good news is these really annoying paint systems tend to be few and far between, but they can be factory paint or repaints. We had the exact same issue on a restored (and therefore repainted) 1959 Ferrari 250GT that we detailed at RM Auctions in Monterey, CA a couple of years ago. Everything else was fine on it except Ultimate Polish.

    Again, from personal experience, I've worked a car, just one, where M105 was instantly turned into a gummy mess on the surface and was completely unusable. I've seen one car, just one, where every single quick detailer used on it left a film that you could run your fingers through and leave streaks, but those streaks would eventually disappear as the film took over the clear areas. Just the craziest thing, but it turned out eventually that M34 Final Inspection was perfectly fine on it. The car had been waxed with NXT Tech Wax 2.0, which we've seen on thousands of cars without causing any sort of issue with any quick detail spray.

    We could go on and on with examples of paint systems that react in really bizarre ways to very common inputs and products but we think you get the point here. Of course, for someone new to this hobby it's extremely frustrating and very hard to sort out how to overcome the challenge. Detailing forums like MOL and others, along with manufacturer's call centers and even discussions on Facebook exist for these reasons - to help people figure out the hows and whys of detailing.
    Michael Stoops
    Senior Global Product & Training Specialist | Meguiar's Inc.

    Remember, this hobby is supposed to be your therapy, not the reason you need therapy.

  4. #14
    Registered Member mikepro66's Avatar
    Join Date
    Mar 2015
    Location
    Athens Georgia
    Age
    54
    Posts
    6
    Rep Power
    7

    Re: Problems with Meguiars Ultimate Polish

    I use Ultimate polish, Sometimes it wipes right off, sometimes its hard to remove. For my self... I use a quick detailer spray or right now I have a big bottle of speed shine from griot's. just a light spray and it comes right off. I use the same method for Ultimate compound if it gets hard to remove.

  5. #15
    Registered Member
    Join Date
    May 2021
    Location
    Canada
    Posts
    1
    Rep Power
    1

    Re: Problems with Meguiars Ultimate Polish

    the cowpown makes lines and they do not leave what to do

  6. #16
    Registered Member
    Join Date
    Jun 2014
    Location
    Sault Ste Marie Ontario Canada
    Posts
    89
    Rep Power
    7

    Re: Problems with Meguiars Ultimate Polish

    if you are having issues removing product and it is leaving a haze. Try using a clean wet cloth to wipe the product off. I find it help especially when it is dry. Good luck

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Black car with swirls and problems with Ultimate Compound
    By Bpinheiro in forum Detailing 101
    Replies: 12
    Last Post: May 29th, 2012, 11:09 AM
  2. My Pontiac after going over it with Meguiars Ultimate wash, polish and wax...
    By strader327 in forum Show Off Your Latest Detail Work
    Replies: 4
    Last Post: Jul 19th, 2011, 10:06 PM
  3. Ultimate compound problems :/
    By BMW-5 in forum Detailing 101
    Replies: 28
    Last Post: Feb 2nd, 2011, 05:36 PM
  4. Meguiars #205 - The Ultimate Finishing Polish? My Thoughts
    By Kickin Griffin in forum Professional Line - Product Reviews
    Replies: 20
    Last Post: Aug 4th, 2010, 04:44 PM
  5. Some problems with cleaner and polish!
    By figgek in forum Detailing 101
    Replies: 9
    Last Post: Feb 13th, 2007, 12:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •