PC 7424 not spinning
Results 1 to 10 of 10

Thread: PC 7424 not spinning

          
  1. #1
    Registered Member KBzPTGT's Avatar
    Join Date
    Sep 2005
    Location
    MD
    Posts
    69
    Rep Power
    14

    PC 7424 not spinning

    over the past year or so my PCda non XP model has increasingly stopped dual actioning? It just jiggles if i apply any pressure whatso ever. It's basically a wax spreader now. As far as I can tell all screws/bolts are tight on the unit. (not the user) I only use it a few times a year so i wouldn't think its wearing out. An suggestions other than of upgrading?

    Thanks,
    KB
    See Kevin's '03 PT Cruiser GT here: http://www.cardomain.com/ride/477590

  2. #2
    Registered Member Meticulous-Detail's Avatar
    Join Date
    Nov 2009
    Location
    Stang Island, NY
    Posts
    791
    Rep Power
    17
    Maybe the brushes are worn out. I think they included an extra set when you purchased the PC. Go on their website and check FAQ or troubleshooting. Should have instructions on how to change brushes too. Worse comes to worse just give them a call.

    http://www.meticulous-detail.com/
    "The Prep makes the Pop, not what's on Top"



  3. #3
    Registered Member
    Join Date
    Feb 2013
    Location
    Wy
    Posts
    1
    Rep Power
    7

    Re: PC 7424 not spinning

    Make sure you dont have a build up of dust or product between the washer and machine.

  4. #4
    Detailing BoZo jfelbab's Avatar
    Join Date
    Apr 2004
    Location
    Cape Coral, FL
    Posts
    1,484
    Rep Power
    31

    Re: PC 7424 not spinning

    You didn't discard the washer from the backing plate by any chance???

    FWIW, Every year or two,I take my PC to a local ACE hardware which is an authorized Porter-Cable repair center and they clean and lube the head assembly and replace brushes as needed. My PC is now 18 years old.

  5. #5
    Registered Member Detailing by M's Avatar
    Join Date
    Jul 2011
    Location
    Plano Tex-***
    Posts
    2,202
    Rep Power
    30
    It should be broken. Mine is 10 years old and works great.
    Check to se if you have the washer. This is a common mistake.
    Also turn up the power!, jk

  6. #6
    Registered Member KBzPTGT's Avatar
    Join Date
    Sep 2005
    Location
    MD
    Posts
    69
    Rep Power
    14

    Re: PC 7424 not spinning

    When i first read about the missing washer issue i checked both of my backing plates and they were good to go.
    I have not checked them lately though. I'll check them out again to make sure the washers are still intact.
    AS far as turning up the power the only way to get it to do it's DA thing is to run it on 6. Any other setting it just jiggles.
    See Kevin's '03 PT Cruiser GT here: http://www.cardomain.com/ride/477590

  7. #7
    Registered Member Detailing by M's Avatar
    Join Date
    Jul 2011
    Location
    Plano Tex-***
    Posts
    2,202
    Rep Power
    30

    Re: PC 7424 not spinning

    dam typo, yours shouldn't be broken.
    and if speed six fixes the issue then it sounds like a missing washer

  8. #8
    Registered Member KBzPTGT's Avatar
    Join Date
    Sep 2005
    Location
    MD
    Posts
    69
    Rep Power
    14

    Re: PC 7424 not spinning

    i understood
    See Kevin's '03 PT Cruiser GT here: http://www.cardomain.com/ride/477590

  9. #9
    Registered Member KBzPTGT's Avatar
    Join Date
    Sep 2005
    Location
    MD
    Posts
    69
    Rep Power
    14

    Re: PC 7424 not spinning

    ok before i get out the BFH and prybar, how does the black cover come off to get to the carbon brushes? it looks simple enough but it has me stumped atm.
    See Kevin's '03 PT Cruiser GT here: http://www.cardomain.com/ride/477590

  10. #10
    Registered Member
    Join Date
    Feb 2011
    Location
    Hanover, Pa.
    Posts
    4
    Rep Power
    9

    Re: PC 7424 not spinning

    KBzPTGT, I just ran into the exact same problem that you have and I'm guessing there's gearing inside that isn't meshing.
    I can get the PC apart but cant seem to get into the gearing area.
    Let me know if you come up with anything.

    And I did try the washer/spacer and it's there, and no help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. G110V2 Pad not spinning
    By Psaint in forum Detailing 101
    Replies: 21
    Last Post: Oct 11th, 2017, 11:29 PM
  2. pad spinning off
    By jazzpants in forum Machines - The Dual Action Polisher
    Replies: 27
    Last Post: Mar 9th, 2013, 02:11 PM
  3. Keeping the pad spinning
    By adamracer91 in forum Machines - The Dual Action Polisher
    Replies: 1
    Last Post: Apr 18th, 2009, 12:15 AM
  4. G100/PC - Should it be spinning all the time?
    By Monk in forum Hot Topics & Frequently Asked Questions
    Replies: 36
    Last Post: Jan 17th, 2009, 06:36 AM
  5. PC and my head is spinning
    By silence in forum Detailing 101
    Replies: 13
    Last Post: Jul 7th, 2005, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •