Death of an MT300 - Power Cord Issue - Page 3
Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Death of an MT300 - Power Cord Issue

          
  1. #21
    Registered Member
    Join Date
    Feb 2016
    Location
    Conway, NH
    Posts
    3
    Rep Power
    4

    Re: Death of an MT300 - Power Cord Issue

    Quote Originally Posted by The Guz View Post
    Contact Brian Han. He is great to deal with.


    Brian Hann
    Customer Care Center
    Meguiar's Inc.
    (800) 854-8073 *3870
    bhann@meguiars.com


    Your issues sound just like mine and I suspect it is the power cord.

    I had the same issue a second time

    http://www.meguiarsonline.com/forums...wer-Cord-Issue

    I used it over the weekend after the second repair and it worked fine.

    Thanks for the information. I had the assembly apart and the cord is easy to replace. In fact, it would take 10 minutes or less and the price would be reasonable. I'll see what Brian has to say . . .

  2. #22
    Manager - Meguiar's Solutions Hub Brian Hann's Avatar
    Join Date
    Feb 2005
    Posts
    543
    Rep Power
    20

    Re: Death of an MT300 - Power Cord Issue

    Uber_Fritz,

    Sorry to hear about this. We also received your two other emails this weekend. The best course of action is to have the machine fully diagnosed and then repaired under warranty at our service center. You should expect an email in the next few hours requesting further information from you and instructions related to warranty repair.
    Brian Hann
    Manager - Meguiar's Solutions Hub
    Meguiar's Inc.
    Irvine, California
    bhann@meguiars.com
    (800) 854-8073 *3870

  3. #23
    Registered Member
    Join Date
    Feb 2016
    Location
    Conway, NH
    Posts
    3
    Rep Power
    4

    Re: Death of an MT300 - Power Cord Issue

    Well, my problem has been rectified and it was nothing that I did. Give ALL the credit to Danny Hernandez and his efforts. You can reach Danny at the following: djhernandez@meguiars.com. Danny is articulate and is focused on customer satisfaction. My DT unit was shipped, meticulously tested and cleaned. If looks so good when I got the return, I thought it was new. Irrespective, it behaves as if it's new and I am very pleased. Again, I cannot say enough about my dealings with Danny; he is a great representative of the company and an ambassador of good faith dealing!

  4. #24
    Prince of Insufficent Light Marc Hufnagel's Avatar
    Join Date
    Mar 2004
    Location
    Carbondale, IL
    Posts
    366
    Rep Power
    19

    Re: Death of an MT300 - Power Cord Issue

    sounds great but my dilemma is a bad one. I purchased one last April, in and out of the hospital all Summer into the Fall. You guessed it - brand new in the box and about 3 weeks on the warranty.

    I won't have time to get to polishing until at least May.

    Meguiars - any help in this one? I know it's a weird situation but I can see the cord most likely acting just like others after even perhaps one car.
    2018 Subaru Outback 3.6R Touring - Crystal White Pearl

  5. #25
    Michael The Guz's Avatar
    Join Date
    Jul 2013
    Location
    Lawndale, CA
    Age
    40
    Posts
    5,455
    Rep Power
    63

    Re: Death of an MT300 - Power Cord Issue

    Quote Originally Posted by Hellspawn View Post
    sounds great but my dilemma is a bad one. I purchased one last April, in and out of the hospital all Summer into the Fall. You guessed it - brand new in the box and about 3 weeks on the warranty.

    I won't have time to get to polishing until at least May.

    Meguiars - any help in this one? I know it's a weird situation but I can see the cord most likely acting just like others after even perhaps one car.
    All can be found here.

    Quote Originally Posted by The Guz View Post
    Contact Brian Han. He is great to deal with.


    Brian Hann
    Customer Care Center
    Meguiar's Inc.
    (800) 854-8073 *3870
    bhann@meguiars.com

  6. #26
    Manager - Meguiar's Solutions Hub Brian Hann's Avatar
    Join Date
    Feb 2005
    Posts
    543
    Rep Power
    20

    Re: Death of an MT300 - Power Cord Issue

    Hellspawn,

    We typically do not like to deal in what-if scenarios. If you have an issue please contact us at that time. I will say that although a warranty does have to hold some weight we try to address each situation uniquely within reason. If you are more comfortable contacting me directly, should the need arise, please do so.
    Brian Hann
    Manager - Meguiar's Solutions Hub
    Meguiar's Inc.
    Irvine, California
    bhann@meguiars.com
    (800) 854-8073 *3870

  7. #27
    Prince of Insufficent Light Marc Hufnagel's Avatar
    Join Date
    Mar 2004
    Location
    Carbondale, IL
    Posts
    366
    Rep Power
    19

    Re: Death of an MT300 - Power Cord Issue

    Quote Originally Posted by Brian Hann View Post
    Hellspawn,

    We typically do not like to deal in what-if scenarios. If you have an issue please contact us at that time. I will say that although a warranty does have to hold some weight we try to address each situation uniquely within reason. If you are more comfortable contacting me directly, should the need arise, please do so.
    I didn't know if things were cast in stone. I hope not to have an issue when I start using it but it does seem like there is a bit of problems. I am going to try to get to a car in April if I can just to see. thank you for responding.
    2018 Subaru Outback 3.6R Touring - Crystal White Pearl

  8. #28
    Registered Member SaltyWater's Avatar
    Join Date
    Sep 2016
    Location
    LI NY
    Posts
    7
    Rep Power
    4

    Re: Death of an MT300 - Power Cord Issue

    I wanted to post this here also as it is important for people trying to make a decision on an MT300 According to Meg's the issue was fixed.

    "Thank you for your inquiry. We routinely make improvements to products and did indeed upgrade a couple parts related to the cord towards the end of last year. All new machines manufactured since then also received the new components. At this point it is likely that most large distributors have new machines in stock but there is no way for us to check specifically on that information with any given vendor. Keep in mind the machine comes with a one year warranty so if anything happens in that year it will be fully repaired at our expense. Hope that is helpful. If you need anything else at all please do not hesitate to give us a call"

    Read more at http://www.meguiarsonline.com/forums...oto07MgUrt6.99

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How likely will I have the G110 V2 Power Cord Issue?
    By mb911 in forum Machines - The Dual Action Polisher
    Replies: 5
    Last Post: May 7th, 2013, 04:56 PM
  2. 110v2 bad power cord!
    By Bugguy67 in forum Machines - The Dual Action Polisher
    Replies: 5
    Last Post: Jan 12th, 2013, 05:30 PM
  3. Dual action cord issue
    By garcin in forum Customer Service Hotline
    Replies: 1
    Last Post: Jul 14th, 2012, 06:14 AM
  4. G110v2 power cord
    By guy in forum Customer Service Hotline
    Replies: 4
    Last Post: Jun 7th, 2010, 08:38 AM
  5. extension power cord.. G110v2
    By Alexandre in forum Detailing 101
    Replies: 8
    Last Post: Apr 17th, 2010, 07:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •