Has the MT300 DA power cord defect been remedied?
Results 1 to 7 of 7

Thread: Has the MT300 DA power cord defect been remedied?

          
  1. #1
    Registered Member SaltyWater's Avatar
    Join Date
    Sep 2016
    Location
    LI NY
    Posts
    7
    Rep Power
    4

    Has the MT300 DA power cord defect been remedied?

    If so what is the build date when the issue was solved?

    Thanks

  2. #2
    Registered Member Mr. Slick's Avatar
    Join Date
    Dec 2015
    Location
    Palm Springs
    Posts
    159
    Rep Power
    5

    Re: Has the MT300 DA power cord defect been remedied?

    I'm wondering the same thing because I might buy one of these.

  3. #3
    Registered Member SaltyWater's Avatar
    Join Date
    Sep 2016
    Location
    LI NY
    Posts
    7
    Rep Power
    4

    Re: Has the MT300 DA power cord defect been remedied?

    Quote Originally Posted by Mr. Slick View Post
    I'm wondering the same thing because I might buy one of these.

    I read somewhere, maybe here, where someone copied & pasted a reps response & he said that it was resolved with a new cord but i would like to hear it from the horses mouth. You would think they would say it & say it LOUD that it was fixed....people are still holding off on them as they don't want to drop 2 bills to have to ship it back & i don't blame them one bit. On the other hand, if it is fixed, YELL it out so i can spend my money! lol

    I am going to call them tomorrow

  4. #4
    Registered Member SaltyWater's Avatar
    Join Date
    Sep 2016
    Location
    LI NY
    Posts
    7
    Rep Power
    4

    Re: Has the MT300 DA power cord issue been fixed?

    I got an answer from Brian Hann from Meg's apparently it was resolved at the end of 2015. I wish they would have updated the advert or something as many of us held off on it. I just purchased one! Below is his email response.

    "Thank you for your inquiry. We routinely make improvements to products and did indeed upgrade a couple parts related to the cord towards the end of last year. All new machines manufacturedsince then also received the new components. At this point it is likely that most large distributors have new machines in stock but there is no way for us to check specifically on that information with any given vendor. Keep in mind the machine comes with a one year warranty so if anything happens in that year it will be fully repaired at our expense. Hope that is helpful. If you need anything else at all please do not hesitate to give us a call"

  5. #5
    Registered Member
    Join Date
    Jul 2016
    Location
    Los Angeles, CA
    Posts
    6
    Rep Power
    4

    Re: Has the MT300 DA power cord defect been remedied?

    I bought the Meguiar's DA from Amazon a few weeks ago and just did my second car yesterday and it was crapped out on me.

  6. #6
    Product & Training Specialist |MOL Admin Nick Winn's Avatar
    Join Date
    Sep 2010
    Location
    Irvine, CA
    Posts
    7,985
    Rep Power
    90

    Re: Has the MT300 DA power cord defect been remedied?

    Quote Originally Posted by mustanger66 View Post
    I bought the Meguiar's DA from Amazon a few weeks ago and just did my second car yesterday and it was crapped out on me.
    Hi mustanger66,

    We are sorry to hear about the trouble with our MT300 DA. This thread has been moved to our Customer Service Hotline. The manager of our Solutions Hub will be notified of the post via e-mail and will likely send you a PM soon.
    Nick Winn
    Product & Training Specialist | Meguiar's Online Forum Administrator
    Meguiar's Inc.
    Irvine, CA
    nawinn@meguiars.com
    800-854-8073 ext 3845

    CLICK HERE TO REGISTER AS A MEMBER FOR MEGUIAR'S ONLINE DISCUSSION FORUM

  7. #7
    Manager - Meguiar's Solutions Hub Brian Hann's Avatar
    Join Date
    Feb 2005
    Posts
    543
    Rep Power
    20

    Re: Has the MT300 DA power cord defect been remedied?

    mustanger66,

    Sorry to hear that. I am sure that is disappointing and very frustrating. Please give our Solutions Hub a call at (800) 347-5700 to get the warranty process started.
    Brian Hann
    Manager - Meguiar's Solutions Hub
    Meguiar's Inc.
    Irvine, California
    bhann@meguiars.com
    (800) 854-8073 *3870

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Death of an MT300 - Power Cord Issue
    By The Guz in forum Customer Service Hotline
    Replies: 27
    Last Post: Sep 7th, 2016, 10:46 PM
  2. Oh no not again. MT300 Power Cord Issue
    By The Guz in forum Customer Service Hotline
    Replies: 7
    Last Post: Jan 29th, 2016, 12:27 PM
  3. 110v2 bad power cord!
    By Bugguy67 in forum Machines - The Dual Action Polisher
    Replies: 5
    Last Post: Jan 12th, 2013, 05:30 PM
  4. Power Cord issues with my Meguiars DA
    By Rocksteady-Rebel in forum Customer Service Hotline
    Replies: 3
    Last Post: Jan 9th, 2013, 10:31 PM
  5. G110v2 power cord
    By guy in forum Customer Service Hotline
    Replies: 4
    Last Post: Jun 7th, 2010, 08:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •