MT300 power cord issue + out of warranty
Results 1 to 10 of 10

Thread: MT300 power cord issue + out of warranty

          
  1. #1
    Registered Member
    Join Date
    Jun 2010
    Location
    Watsonville, CA 95076
    Posts
    56
    Rep Power
    9

    MT300 power cord issue + out of warranty

    Unfortunately I had the power cord problem happen to me where the machine will turn on only if you wiggle the power cord to the right spot for it to power on. This was purchased back in 5/9/15 brand new from www.autodetailingsolutions.net and saw very few action throughout the years.. I'd say about 5 cars in total. Obviously it's out of the warranty time period so I have to probably fix it my self, does anyone had tips or suggestions on how to go about this?

  2. #2
    Michael The Guz's Avatar
    Join Date
    Jul 2013
    Location
    Lawndale, CA
    Age
    39
    Posts
    5,321
    Rep Power
    60

    Re: MT300 power cord issue + out of warranty

    Sorry to hear you experienced this issue. It happened to my MT300 twice after the same amount of vehicles you used yours on. Both times it was covered under warranty Meguiar's. The second time I was out of warranty. But Brian of Meguiar's took care of it. So there is hope.

    I have used it a handful of times and it works fine now.

    If it is not covered then you can buy a new power cord and replace it yourself.

    I ended up posting in this location to inform the Meguiar's customer service rep.

    https://meguiarsonline.com/forums/fo...ervice-Hotline

  3. #3
    Registered Member
    Join Date
    Jun 2010
    Location
    Watsonville, CA 95076
    Posts
    56
    Rep Power
    9

    Re: MT300 power cord issue + out of warranty

    Woops I forgot that was the section one is supposed to post these kind of topics. Then again I've been absent from the forums for a while. Clicked on the link you provided and saw the second post was from me when my G110v2 had the same issue, now my MT300 as well But yea I gonna keep digging around to see if I can fix it, don't want to take it apart just yet. Won't have a clue what I'm doing. Thank you for the reply.

  4. #4
    Product & Training Specialist |MOL Admin Nick Winn's Avatar
    Join Date
    Sep 2010
    Location
    Irvine, CA
    Posts
    6,680
    Rep Power
    76

    Re: MT300 power cord issue + out of warranty

    Sorry to hear about your trouble David32. We would encourage you to please contact our Solutions Hub at 800-347-5700 or customercare@meguiars.com.
    Nick Winn
    Product & Training Specialist | Meguiar's Online Forum Administrator
    Meguiar's Inc.
    Irvine, CA
    nawinn@meguiars.com
    800-854-8073 ext 3845

  5. #5
    Registered Member
    Join Date
    Jun 2010
    Location
    Watsonville, CA 95076
    Posts
    56
    Rep Power
    9

    Re: MT300 power cord issue + out of warranty

    Just did now just waiting to hear back

  6. #6
    Registered Member
    Join Date
    Jun 2010
    Location
    Watsonville, CA 95076
    Posts
    56
    Rep Power
    9

    Re: MT300 power cord issue + out of warranty

    did a video of showing what mine does, sorry for choppy video.. did it on a somewhat old camcorder: https://youtu.be/Y_4vhuo6S0s

  7. #7
    Manager - Meguiar's Solutions Hub Brian Hann's Avatar
    Join Date
    Feb 2005
    Posts
    502
    Rep Power
    19

    Re: MT300 power cord issue + out of warranty

    David,

    I just emailed you.
    Brian Hann
    Manager - Meguiar's Solutions Hub
    Meguiar's Inc.
    Irvine, California
    bhann@meguiars.com
    (800) 854-8073 *3870

  8. #8
    Registered Member snozan's Avatar
    Join Date
    Jul 2016
    Location
    Sweden
    Age
    41
    Posts
    132
    Rep Power
    4

    Re: MT300 power cord issue + out of warranty

    Just out of curiosity, seems like issues like this is fixed in a smooth way for you US peeps. But what about us EU peeps? I bougfht one aswell, havn't tried it yet though but what if my breaks the same. I can't call a solution hub because that would cost more in a phone bill then a new machine.

    In what way are we covered or are we self to blame that we don't live in US when things go wrong outside the warranty?

  9. #9
    Manager - Meguiar's Solutions Hub Brian Hann's Avatar
    Join Date
    Feb 2005
    Posts
    502
    Rep Power
    19

    Re: MT300 power cord issue + out of warranty

    This could be a much bigger conversation about international distribution but as it relates to your specific question you should typically contact the appropriate international partner responsible for your part of the world.
    Brian Hann
    Manager - Meguiar's Solutions Hub
    Meguiar's Inc.
    Irvine, California
    bhann@meguiars.com
    (800) 854-8073 *3870

  10. #10
    Registered Member snozan's Avatar
    Join Date
    Jul 2016
    Location
    Sweden
    Age
    41
    Posts
    132
    Rep Power
    4

    Re: MT300 power cord issue + out of warranty

    Quote Originally Posted by Brian Hann View Post
    This could be a much bigger conversation about international distribution but as it relates to your specific question you should typically contact the appropriate international partner responsible for your part of the world.
    Thank you for answer I keep my fingers crossed it won't break, and if it's only a cable that breaks i might be able to fix it myself if something goes wrong outside warranty. the MT300 (MT310 in Sweden) aren't cheap. Costs around $400 so it isn't something you just buy a new one if it breaks Thats why i asked.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has the MT300 DA power cord defect been remedied?
    By SaltyWater in forum Customer Service Hotline
    Replies: 6
    Last Post: Sep 19th, 2016, 09:58 AM
  2. Death of an MT300 - Power Cord Issue
    By The Guz in forum Customer Service Hotline
    Replies: 27
    Last Post: Sep 7th, 2016, 10:46 PM
  3. Oh no not again. MT300 Power Cord Issue
    By The Guz in forum Customer Service Hotline
    Replies: 7
    Last Post: Jan 29th, 2016, 12:27 PM
  4. How likely will I have the G110 V2 Power Cord Issue?
    By mb911 in forum The Dual Action Polisher
    Replies: 5
    Last Post: May 7th, 2013, 04:56 PM
  5. Dual action cord issue
    By garcin in forum Customer Service Hotline
    Replies: 1
    Last Post: Jul 14th, 2012, 06:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •