Hello from NZ!
Results 1 to 2 of 2

Thread: Hello from NZ!

          
  1. #1
    Registered Member
    Join Date
    Aug 2020
    Location
    Auckland, New Zealand
    Posts
    2
    Rep Power
    1

    Hello from NZ!

    Hi all!

    Greetings from Auckland, New Zealand! Love my Meguiar's products! And can't wait to try out Meguiar's Hybrid Ceramic Wax asap
    A bit of advice please it possible? My 2013 Holden Commodore has this growth(?) on the rubber trim (see pic). I've tried some light abrasives on it which doesn't appear to do anything so any help would be greatly appreciated for any advice.

    Cheers

    Matt

    [IMG]IMG_0286 by Matt Wilson, on Flickr[/IMG]

  2. #2
    Registered Member
    Join Date
    Aug 2020
    Location
    Auckland, New Zealand
    Posts
    2
    Rep Power
    1

    Re: Hello from NZ!

    Wow, did I make some errors in my haste to get a message out quickly It should read:

    A bit of advice please if possible? My 2013 Holden Commodore has this growth(?) on the rubber trim (see pic). I've tried some light abrasives on it which doesn't appear to do anything so any help would be greatly appreciated or any advice on what to try next. (It's also spring in NZ so you can see all the pollen all over my car!)

    Thanks all, cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •